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Welcome
Introduction
Welcome and thank you for using version v1.0.3 of the Pharos Dynamic MediaManager software. This is the first
public release of this software.

Platforms
Pharos Dynamic MediaManager is designed to run on a PC runningMicrosoft Windows 7, Vista or XP (SP2+) or an
AppleMac running OS X (10.5.x or later - Intel only). As the application is of a highly graphical nature a largemonitor
is recommended (800x600minimum) .

Help Overview
The Help is split into four major sections: Quick Start, Reference, Troubleshooting, and Appendices.

Those of you experimenting with the software for the first time should work through theQuick Start guide to famil-
iarise yourself with the basics of the software. The Reference section then gives detailed descriptions of every
aspect of the software. The Troubleshooting section provides help to resolve any problems while the Appendices pro-
vide additional useful resources.

Help Help
This is the PDF version of the online Help and it is available in various formats for printing. The online version, which
has the advantage of being fully searchable, can be opened from within Dynamic MediaManager by clicking the
help button on themain toolbar.

Support
As with all successful control products, support is crucial and the team at Pharos will do everything possible to
ensure that your project is a success. Please do not hesitate to contact us with your questions, bug reports and sug-
gestions at:

T: +44-(0)20-7471-9229
E: support@pharoscontrols.com

Please also visit our website to keep up to date with the latest product news and software releases: www.ph-
aroscontrols.com.
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What's New in v1.0.3

What's New in v1.0.3
l Multithreading support for exportingmedia
l New web help
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Overview
Pharos Dynamic MediaManager is a tool to programmedia sequences ontomedia slots that have been imported
from one or more Pharos Designer projects. Media slots are programmed onto pixel matrices in Pharos Designer to
act as placeholders for media that will be generated after the Designer project has been uploaded to Pharos Con-
trollers. By uploadingmedia sequences created by Pharos Dynamic MediaManager to Pharos Controllers, you can
change themedia content of timelines without needing to open or modify the Designer project file.

Themedia slots frommultiple Pharos Designer projects can be imported into one Pharos Dynamic MediaManager
project, which allows themedia for large, multi-project installations to bemanaged simultaneously.

Pharos InstallationManager can be used to quickly and easily upload themedia exported from Dynamic MediaMan-
ager to the correct Pharos Controllers, either across a local network or across the Internet.
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User Interface

User Interface
The software has been designed to present a consistent graphical user interface and so it is worth familiarising your-
self with the layout of themain window before proceeding further:

Main toolbar
The buttons on the left of themain toolbar provide overall control of your Dynamic MediaManager project. Create
new projects, open existing projects and save your work using the file management buttons. Use the Undo/Redo but-
tons to step backwards and forwards through operations that affect your project. The Import button allows you to add
media slots to your project, as exported from a Pharos Designer project file, and the Export button generates the files
needed for each Controller to be able to play back your media slot programming.

Media Slot Browser
Any media slots that have been imported into your Dynamic MediaManager project are listed here. Media slots from
different Designer projects with the same namewill only be listed once. The length of eachmedia slot, as configured
when themedia slot was created in Designer, is also listed. To begin editing the programming for amedia slot, click
it in this browser to select it. Click here to find out more about managingmedia slots.

Designer Project Control
The drop-down list can be used to filter themedia slots displayed in themedia slot browser by Designer project. All
themedia slots imported from aDesigner project can be removed from the Dynamic MediaManager project by click-
ing the button.
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Media Preset Library
Create new lighting presets from the built-in matrix effects, or import your own video and images. You can also
create custom presets using Lua scripts. Click here to find out more about media presets.

Media Slot Timeline Editor
The programming for the currently selectedmedia slot is displayed here. Elements can be reordered by drag & drop.
Transitions can be edited by clicking the button. Media presets are added to the timeline by dragging them from
themedia preset library. The total length of the programming is displayed to the right of themedia slot timeline editor.
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Keyboard shortcuts

Keyboard shortcuts
For ease and speed of use various keyboard keys map to application commands:

● F1 Launch the online help.

● Ctrl + N New project.

● Ctrl + O Open project.

● Ctrl + S Save project.

● Ctrl + Z Undo the last operation.

● Ctrl + Shift + Z

● Ctrl + Y
Redo the last operation to be undone.

Notes for Macintosh users
Pharos Dynamic MediaManager makes a good deal of use of the two buttonmouse with right-click being used to
invoke context-sensitivemenus. As themajority of Mac users have only a single buttonmouse they must hold Ctrl
while clicking to get this functionality. FurthermoreMacs have an Command key that serves as the alternative to the
Windows Ctrl key. Shift and Alt work as described forWindows.
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Project Files
Pharos Dynamic MediaManager projects are saved with the file extension ".dmm".

Creating a new project

Click or press Ctrl+N. You will be prompted to choose a location to save your new project and then a blank
project will be created with nomedia slots or media presets.

Opening a project

Click or press Ctrl+O. You will be prompted to choose an existing .dmm file to load. As the project loads,
Dynamic MediaManager checks if all themedia files referenced in the project exist. If not, you will be prompted to
locate these files.

Saving a project

Click or press Ctrl+S.

To save to a different file or to export your project complete with all your media files, click and choose either
Save As or Export Project. You will be prompted to choose a new location to save to. After Save As, subsequent
saves will go to the new file.
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Media Slots & Pixel Matrices

Media Slots & Pixel Matrices
Importing Media Slots & Pixel Matrices
Pharos Designer exports media slots to files with extension ".pmm". These files contain information about themedia
slots and the pixel matrices onto which they're programmed. To generate a .pmm file in Designer, go to File > Export
for MediaManager.

Click . You will be prompted to choose a .pmm file to import from.

Importedmedia slots will appear in themedia slot browser on the left of the application window. Their name and
length is shown.

If youmake changes to your Designer project, simply go to File > Export for MediaManager in Designer again and
import the .pmm file into your existing Dynamic MediaManager project. Youmedia slots will be updated with the
new details.

Filtering Media Slots
Themedia slots in themedia slot browser can be filtered by the Designer project(s) in which they're used.

Select a Designer project from the drop-down list underneath themedia slot browser. Only themedia slots used by
the selected Designer project will be shown in themedia slot browser.

Removing Media Slots & Pixel Matrices
Media slots and pixel matrices cannot be removed individually, but all themedia slots and pixel matrices imported
from aDesigner project can be removed together.

Select a Designer project from the drop-down list underneath themedia slot browser, then click . All the pixel
matrices imported from the Designer project will be removed, along with any media slots that aren't referenced by
any other imported Designer project(s).
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Media Presets
Media presets are the building blocks of media slot programming. You can createmedia presets from built-in matrix
effects, existing video and image files, or code your own using Lua scripts.

2D Matrix Presets

Creating a 2D Matrix Preset

Select the 2D Matrix tab on the right of the application window. Click Create New. The 2D Matrix preset editing
dialog will appear.
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Media Presets

Click OK when you've finished setting up your 2D matrix preset. The new 2D matrix preset will appear in the 2D
matrix preset library as a thumbnail image and the name of the effect.

Renaming a 2D Matrix Preset

Double-click a 2D matrix preset in the library and type a new name.

Editing a 2D Matrix Preset

Tomodify an existing 2D matrix preset, select the 2D matrix preset in the library and click Edit or right-click the 2D
matrix preset and select Edit. The 2D matrix editing dialog will appear. Click OK when you've finished editing, or
Cancel to discard your changes.

Any media slots that use this 2D matrix preset will now use the new settings.

Deleting a 2D Matrix Preset

Select the 2D matrix prest in the library and click Delete or right-click the 2D matrix preset and select Delete.

Video Presets

Creating a Video Preset

Select theVideo tab on the right of the application window. Click Create New . You will be prompted to choose an
existing video file. The new video preset will appear in the video preset library as a thumbnail image and its file name.

Renaming a Video Preset

Double-click a video preset in the library and type a new name.

Changing a Video Preset

To change the source file of an existing video preset, select the video preset in the library and click Locate or right-
click the video preset and select Locate. You will be prompted to select an existing video file.

Any media slots that use this video preset will now use the new video source file.

Deleting a Video Preset

Select the video preset in the library and click Delete or right-click the video preset and select Delete.

Image Presets

Creating an Image Preset

Select the Image tab on the right of the application window. Click Create New . You will be prompted to choose an
existing image file. The new image preset will appear in the image preset library as a thumbnail image and its file
name.
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Renaming an Image Preset

Double-click an image preset in the library and type a new name.

Changing an Image Preset

To change the source file of an existing image preset, select the image preset in the library and click Locate or right-
click the image preset and select Locate. You will be prompted to select an existing image file.

Any media slots that use this image preset will now use the new image source file.

Deleting an Image Preset

Select the image preset in the library and click Delete or right-click the image preset and select Delete.

Custom Presets

Creating a Custom Preset

Select theCustom tab on the right of the application window. Click Create New. The custom preset editing dialog
will appear.
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Media Presets

For help with writing custom presets for Pharos in Lua, please read theCustom Preset ProgrammingGuide appen-
dix in the Pharos Designer help.

Click OK when you've finished writing and configuring your custom preset. The new custom preset will appear in the
custom preset library as a thumbnail image.

Renaming a Custom Preset

Double-click a custom preset in the library and type a new name.

Editing a Custom Preset

Tomodify an existing custom preset, select the custom preset in the library and click Edit or right-click the 2D
matrix preset and select Edit. The custom preset editing dialog will appear. Click OK when you've finished editing,
or Cancel to discard your changes.

Any media slots that use this custom preset will now use the new settings.
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Deleting a Custom Preset

Select the custom prest in the library and click Delete or right-click the custom preset and select Delete.
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Programming
Media presets can be programmed onto the selectedmedia slot. Transitions can be set up betweenmedia presets.

If the total length of programming on amedia slot is less than the length of themedia slot then the content will loop
when played back by Controllers. If the total length of programming on amedia slot is greater than the length of the
media slot then some cropping will occur.

Adding a Media Preset to a Media Slot
l Select themedia slot to program from themedia slot browser on the left of the application window.
l Click and drag amedia preset from themedia preset library and drop it onto themedia slot timeline at the bot-

tom of the application window.

Reordering Media Presets on a Media Slot Timeline
Click and drag amedia preset on the timeline of amedia slot to change its position in the timeline.

Editing the Length of a Media Preset
Enter the new length into the length editor of themedia preset on themedia slot timeline. If the length is longer than
the length of themedia preset source then themedia preset will loop.

Click next to the length editor of themedia preset on themedia slot timeline to reset the length to the default
value.

Editing the Transition of a Media Preset
Click within themedia preset on themedia slot timeline. The transition editor dialog will appear.

Transition Properties

l Time: the duration of the transition. This cannot bemore than the length of themedia preset.
l Type: how themedia presets should blend into each other.
l Spread: how many pixels should be involved in the transition at once.
l Angle: the start angle for the transition (in degrees).
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Simulation
The programming on eachmedia slot can be simulated for each of the pixel matrices on which themedia slot was
used in Pharos Designer.

Selecting a Pixel Matrix
The current pixel matrix number is displayed on the application toolbar, along with the total number of pixel matrices
on which the selectedmedia slot is used. Use the arrow buttons to change the current pixel matrix.

Adjusting the Simulation View

l Zoom In: click

l Zoom Out: click
l Pan: click and drag to pan the simulation view, or use the scroll bars.

l Show Used Pixels: click to enable this feature. Click again to disable.
l Background Colour: this can be changed in the Preferences dialog.

Simulation Playback
Use the simulation playback buttons on the application toolbar.

l Play:

l Pause:

l Stop:

l Seek Forwards:

l Seek Backwards:

The current point in time for the simulation is shown on the application toolbar.
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Export

Export
Pharos Dynamic MediaManager exports media slot programming in a format suitable for transferring to Pharos Con-

trollers. Click . You will be prompted for a folder to save the generated files.

A successful export will place a folder in the location you have chosen for each Designer project in your Dynamic
MediaManager project. Each folder will be named the same as the Designer project followed by the unique Designer
project ID number surrounded by {} brackets. These folders will contain additional folders, one per Controller in the
Designer project - it is inside each Controller’s folder that theMedia Slot information is stored, ready to be uploaded.

Dynamic MediaManager will only generatemedia for Controllers that were patched in the associated Designer
project. In addition, one or moremedia slots must be programmed onto timelines. You canmake changes to your
Designer project at any time and then update this information in Dynamic MediaManager by importing a new
.pmm file (exported from Designer) into your existing Dynamic MediaManager project.
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Uploading Slots
After you have exported your Dynamic MediaManager slot programming, you now must move these files to each
Controller so that your timelines can use the new slot programming. There are two ways to do this:

Pharos Installation Manager
Provided your Controllers are connected to a network and accessible from your computer, the Pharos Installation
Manager application, free to download from our website, can easily transfer both your Designer project file andmedia
slot information to each Controller. Please refer to the InstallationManager help for how to setup and start using this
application.

FTP Transfer
Provided your Controllers are connected to a network and accessible from your computer, any FTP application can
connect to a Controller and allow you tomove themedia slot files for each Controller to the Controller’s memory
card.
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Preferences

Preferences
Click the down arrow next to the Help button on themain toolbar then click to open the Preferences dialog.

Simulation
Set preferences for how media slot programming is simulated.

Background Colour

Set the background colour of the simulation view. If you havemedia that's predominantly white then it may be helpful
to change the background colour from the default.

Background Lines

Choose whether diagonal lines are displayed on the simulation view as a contrast aid and what their colour is.

Software Update
Choose whether Pharos Dynamic MediaManager checks for new beta versions as well as new releases.
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Frequently asked questions
Is the free software a cut-down demo version?
No. The free Dynamic MediaManager software is the full software package. Downloads and updates can be found
on our website.

Does the Dynamic Media Manager software support the Apple Macintosh?
Yes, from v1.0 we have full support for Intel Macs running Apple OS X 10.5 and later. Project files will be compatible,
regardless of the operating system onwhich they are created.

What are the PC minimum requirements for Dynamic Media Manager?
l Microsoft Windows XP (SP2+ 32bit only), Vista (32/64bit) & 7 (32/64bit)
l Intel processor at 1 GHz or above
l 256MB RAM
l 100MB free hard disk space
l 800x600minimum screen resolution (higher is better)

What are the minimum Macintosh requirements for Dynamic Media Man-
ager?

l AppleMac OS X 10.5.x or later (32bit only)
l Intel processor at 1 GHz or above
l 256MB RAM
l 100MB free hard disk space
l 800x600minimum screen resolution (higher is better)

Are project files compatible across versions and platforms?
Any project file saved in an earlier version of Dynamic MediaManager can be loaded by a later version. Project files
are compatible between the PC andMac versions of the software. However, projects saved in a later version of
Dynamic MediaManager may not be backwards compatible with an earlier version as we reserve the right to make
structural changes to improve the product.

Can I have multiple versions of Dynamic Media Manager on my computer?
Yes, as long as you install the software to a different location each time. However, this could lead to confusion and a
reinstall takes just seconds, so wewould recommend keeping the installers on hand and only having one version
installed at a time.

How many media slots can I import? How many media presets can I create,
etc?
See system limits and capacities.

What are the Pharos Dynamic Media Manager file extensions?
*.dmm Pharos Dynamic MediaManager project file.
*.pmm Generated by Pharos Designer from the File menu, it contains information about themedia slots,

the pixel matrices and the patch for importing into Dynamic MediaManager.
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Frequently asked questions

How do I add media slots to my Pharos Dynamic Media Manager project?
Media slots are added to a Pharos Dynamic MediaManager project when you import a .pmm file that was generated
by Pharos Designer. Media slots in Dynamic MediaManager represent media slots in a Designer project.

What if I make changes to my Designer project?
If youmake any changes to your Designer project after you've already created programming for your media slots in
Dynamic MediaManager then you can simply import the changes into your existingDynamic MediaManager project.
In Designer, go to File > Export for MediaManager to generate the .pmm file again, then click the Import button in
Dynamic MediaManager and select this file. Themedia slots will be updated.

The only changes to a Designer project that will affect Dynamic MediaManager are changes to the patch, pixel
matrices, media slots and the programming of media slots on timelines. If youmake any other changes you do not
need to update your Dynamic MediaManager project.
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Troubleshooting
The following section lists common problems and their solutions.

I've exported my Dynamic Media Manager project but there are no files in the
folders for each Controller?
The fixtures in the pixel matrices in your Designer project must be patched before Dynamic MediaManager can
know which files to generate for which Controller. Open your Designer project, complete the patch and then go to
File > Export for mediamanager to generate the .pmm file again. Return to Dynamic MediaManager and import this
.pmm file into your existing Dynamic MediaManager project. Your media slots will be updated with the new patch
information and you can click the Export button to generate files for your Controllers.

I have checked the FAQ and troubleshooting but I'm still stuck?
Contact support, please be prepared to send in your project files.

- 24 -



Media Slot Anatomy

Media Slot Anatomy
Themedia slots that you create in Pharos Designer have three user-modifiable time elements: the slot Length, Fade
in time and Release time. Adjusting these parameters will affect the output of media slots. Some applications may
require fixed fade times for all slot content while others may want to have these times flexible and set via Dynamic
MediaManager. Each scenario is discussed below:

Typical Slot Usage

When amedia slot is created in Designer you select an overall Length. When the samemedia slot is added to a time-
line you can add Fade in and Release timing as with any preset. Close attention should be paid to these time set-
tings as you begin to addmedia to your slots in Dynamic MediaManager.

Below is a graphical example of a 10 secondmedia slot that has been given a 2 second fade in and a 2 second
release time. Notice that the release time occurs after the slot duration has been reached - you should always place
enoughmedia on a slot to cover the duration & release time.

For example, you could add a 6 second video followed by a 6 second 2D Matrix preset. The two clips total 12 sec-
onds, equalling the duration plus the release time of the slot. When this slot is played on an LPC themedia will start
immediately but full brightness won’t be achieved until the 2 second fade completes. When the duration of 10 sec-
onds has been reached the slot’s 2 second release will begin and complete at the 12 secondmark.

Note: the transition between the effects is set in Dynamic MediaManager and will output as simulated.

Note: Filling a slot completely provides the best playback results whenmedia slots interact with other timeline ele-
ments.

Alternate Slot Usage

Another approach is to allow Dynamic MediaManager to govern all fade and release timing. When adding amedia
slot to a timeline, set both fade and release times to 0 seconds. This allows you to customize the fades when placing
media on the slots within Dynamic MediaManager. The example below offers similar playback as the example
above, except the fade in and release times are set in Dynamic MediaManager. During playback, fade and release
timings happen within the confines of the slot’s duration. The only drawback to this approach is that the transition to
another timeline element will snap through black, rather than crossfading.
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Note: Using fade times on both the slot and the DMMmedia is not recommended and can create some
unexpected transitions.

Looping and Cropping
Becausemedia slots have a fixed duration, the question arises about how a slot will function if you place toomuch
media on it or not enough. Study the examples below to be sure you get what you expect when addingmedia onto
your slots.

Media longer than the slot:

In fig.1 when 10 seconds is reached the video immediately stops playback or takes the slot’s release time if set
above 0. The last 2 seconds of the 14 second video is never seen.

Media does not fill the entire slot:

In fig. 2, a 3.5 second video clip is placed on a 10 second slot with a 2 second fade in and release. During playback
themedia slot will attempt to fill itself with content and therefore loop the 3.5 second clip until the total duration of the
slot is reached.
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Media Slot Anatomy

This example, fig.3 is very similar to fig. 2 above except the slot does not contain a fade or release time. Instead the
4 secondmedia clip contains the fade and release times as set within Dynamic MediaManager. During playback,
the looping nature of the short clip is as above except the fade and release are executed on every loop. The slot
bumps the clip out abruptly when the slot’s duration is reached.
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Software limits & capacities
Pharos Dynamic MediaManager imposes the following project limits which cannot be exceeded:

Media slots 1024
Pixel matrices 2560
Media presets 256
Designer projects 10 The number of different .pmm files that can be imported
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